Forum programmation
 
AccueilPortailFAQRechercherS'enregistrerMembresGroupesConnexion

Partagez | 
 

 ,vou pouvez m'aidez a résoudre ce probleme en algo

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
mahermido
Nouveau
Nouveau
avatar

Nombre de messages : 3
Age : 28
Date d'inscription : 01/02/2007

MessageSujet: ,vou pouvez m'aidez a résoudre ce probleme en algo   Jeu 1 Fév - 23:44

un progrogram permettan daffichier le plu long mot dan un chaine donné,
et le program doi comporté au moin une procédure et une fonction.
exemple: "devoir de controle" le program affiche "controle"
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Chaker
Administrateur
Administrateur
avatar

Nombre de messages : 731
Age : 27
Date d'inscription : 17/01/2007

MessageSujet: Re: ,vou pouvez m'aidez a résoudre ce probleme en algo   Jeu 1 Fév - 23:46

salut couz
je veux avant tout te souhaiter la bienvenu

bien sure qu'on peu t'aider
tu aura la solution bientot

Very Happy:D:D
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
mahermido
Nouveau
Nouveau
avatar

Nombre de messages : 3
Age : 28
Date d'inscription : 01/02/2007

MessageSujet: Re: ,vou pouvez m'aidez a résoudre ce probleme en algo   Ven 2 Fév - 0:03

ok,merCi chaker ,et jespere ke tu pe maidé a résoudre ce probleme
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Admin
super ADMINISTRATEUR
super ADMINISTRATEUR
avatar

Nombre de messages : 258
Age : 33
Date d'inscription : 22/05/2006

MessageSujet: Re: ,vou pouvez m'aidez a résoudre ce probleme en algo   Ven 2 Fév - 0:06

Code:

0) debut algorithme long
1) saisie(ch)
2) longchaine <- pluslong(ch)
3) affiche(longchaine)
4) fin

0) procedure saisie(var ch : chaine)
1) ecrire("Donner la chaine")
2) lire(ch)
3) fin saisie

0) fonction pluslong(ch : chaine) : chaine
1) max <- 0
2) cmpt <- 0
2) pour i de 1 à long(ch) faire
debut
si(ch[i] = " ") alors
si (cmpt > max) alors
max <- cmpt
cmpt <- 0
pos <- i - max + 1
fin si
sinon
cmpt <- cmpt + 1
finsi
fin pour
3) pluslong <- copy(ch,pos,max)
4) fin pluslong

0) procedure affiche(ch : chaine)
1) ecrire("Le plus long mots est :",ch)
2) fin affiche
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://programmation.megabb.com
mahermido
Nouveau
Nouveau
avatar

Nombre de messages : 3
Age : 28
Date d'inscription : 01/02/2007

MessageSujet: Re: ,vou pouvez m'aidez a résoudre ce probleme en algo   Ven 2 Fév - 0:13

merci admin ,alor je vai essayé de tradiur cet algo en pascal ,et je vai voir si il fonctionne ,
mais ,goublier de vou dir kil fau ke cet chaine ne contien pa deu espace consessusif et la chaine doit comporté au moin deu mot
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Chaker
Administrateur
Administrateur
avatar

Nombre de messages : 731
Age : 27
Date d'inscription : 17/01/2007

MessageSujet: Re: ,vou pouvez m'aidez a résoudre ce probleme en algo   Ven 2 Fév - 0:14

Admin a écrit:
Code:

0) debut algorithme long
1) saisie(ch)
2) longchaine <- pluslong(ch)
3) affiche(longchaine)
4) fin

0) procedure saisie(var ch : chaine)
1) ecrire("Donner la chaine")
2) lire(ch)
3) fin saisie

0) fonction pluslong(ch : chaine) : chaine
1) max <- 0
2) cmpt <- 0
2) pour i de 1 à long(ch) faire
debut
si(ch[i] = " ") alors
si (cmpt > max) alors
max <- cmpt
cmpt <- 0
pos <- i - max + 1
fin si
sinon
cmpt <- cmpt + 1
finsi
fin pour
3) pluslong <- copy(ch,pos,max)
4) fin pluslong

0) procedure affiche(ch : chaine)
1) ecrire("Le plus long mots est :",ch)
2) fin affiche

merci Nabil Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Admin
super ADMINISTRATEUR
super ADMINISTRATEUR
avatar

Nombre de messages : 258
Age : 33
Date d'inscription : 22/05/2006

MessageSujet: Re: ,vou pouvez m'aidez a résoudre ce probleme en algo   Ven 2 Fév - 0:26

donc t'as qu'a changé la procedure saisie comme suit :

Code:

0) procedure saisie(var ch : chaine)
1) nbmots = 0
2) deuxespace = false
3) Repeter
ecrire("Donner la chaine")
lire(ch)
pour i de 1 a (long(ch)-1) faire
si (ch[i] = " " et ch[i+1] = " ") alors
deuxespace = true
fin si
si (ch[i] = " ") alors
nbmots = nbmots + 1
finsi
finpour
jusqu'à (nbmots => 2 et deuxespace = false)
3) fin saisie
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://programmation.megabb.com
Chaker
Administrateur
Administrateur
avatar

Nombre de messages : 731
Age : 27
Date d'inscription : 17/01/2007

MessageSujet: Re: ,vou pouvez m'aidez a résoudre ce probleme en algo   Ven 2 Fév - 17:03

merci sa fonctionne
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Admin
super ADMINISTRATEUR
super ADMINISTRATEUR
avatar

Nombre de messages : 258
Age : 33
Date d'inscription : 22/05/2006

MessageSujet: Re: ,vou pouvez m'aidez a résoudre ce probleme en algo   Ven 2 Fév - 20:32

2 rien chaker chui la pour tous vos questions
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://programmation.megabb.com
makram
modérateur
modérateur
avatar

Nombre de messages : 549
Age : 28
Date d'inscription : 29/12/2006

MessageSujet: Re: ,vou pouvez m'aidez a résoudre ce probleme en algo   Sam 3 Fév - 16:03

c'est une exellente réponse au probléme. merci nabil
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Admin
super ADMINISTRATEUR
super ADMINISTRATEUR
avatar

Nombre de messages : 258
Age : 33
Date d'inscription : 22/05/2006

MessageSujet: Re: ,vou pouvez m'aidez a résoudre ce probleme en algo   Sam 3 Fév - 20:01

merci makram
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://programmation.megabb.com
Contenu sponsorisé




MessageSujet: Re: ,vou pouvez m'aidez a résoudre ce probleme en algo   

Revenir en haut Aller en bas
 
,vou pouvez m'aidez a résoudre ce probleme en algo
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Moi c'est Mérillym, vous pouvez m'appeler Méry :D
» Problème de "Vous pouvez répondre au sujet"
» Vous ne pouvez pas repondre aux sujet sur ce forum (invité)
» mauvaise langue aidez-moi svp
» Problème de codage qui ne s'accorde pas. Aidez moi svp.

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum programmation :: Programmation :: Delphi & Pascal :: Pascal :: Exercices-
Sauter vers: