Forum programmation
 
AccueilPortailFAQRechercherS'enregistrerMembresGroupesConnexion

Partagez | 
 

 conversion entre bases de numération (b1 to b2)

Aller en bas 
AuteurMessage
dorsaf
Nouveau
Nouveau


Nombre de messages : 12
Date d'inscription : 29/11/2007

MessageSujet: conversion entre bases de numération (b1 to b2)   Mer 30 Jan - 18:52

Méthode 5 étoile


{Programme Principal}

0) Début conversion

1) Ch <-- "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ"

2) répéter

lire (N )

lire (b1)

jusqu’à Verifie(N,b1) ;

3) Lire (b2)

4) Ecrire (N," en base ",b1, " = ", Base(Base10(N,b1),b2), " en base ",b2)

5) Fin conversion



Algorithme de la Fonction Saisie_nombre

{Ch <-- "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ"}

0) Fonction Verifie (N :chaîne,b1 :entier) : booléen

1) test <-- vrai

Pour i de 1 à long(N) faire

Si Pos(N[i], Ch) > b1 Alors testßfaux

Finsi

Finpour

2) Verifie <-- test

3) Fin verifie



{Transforme le nombre en base 10}

0) Fonction Base10(N :chaine, b1 :entier) :entier

1) b10 <-- 0

Pour i de 1 à long(N) faire

b10 <-- b10 * b1 + Pos(N[i],Ch) - 1

Finpour

2) base10 <-- b10

3) Fin base10



{Transforme le nombre de base 10 en Base : b2}

0) Fonction base(N :entier, b2 :entier) :chaîne

1) b <--""

Tant que (N <> 0) faire

i <-- N mod b2

b <-- ch[i+1]+ b

N <-- N div b2

fintantque

2) Base <-- b

3) fin base
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
djodjo
Nouveau
Nouveau


Nombre de messages : 6
Date d'inscription : 24/01/2008

MessageSujet: Re: conversion entre bases de numération (b1 to b2)   Mar 5 Fév - 11:09

merci pour le prg
djo
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
mtcs
Administrateur
Administrateur
avatar

Nombre de messages : 1605
Date d'inscription : 21/11/2006

MessageSujet: Re: conversion entre bases de numération (b1 to b2)   Mar 5 Fév - 23:18

merci bien
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: conversion entre bases de numération (b1 to b2)   

Revenir en haut Aller en bas
 
conversion entre bases de numération (b1 to b2)
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [RESOLU] "Symbiose" entre SoftwareZator et site web....
» Question sur compatibilité entre carte mére et carte graphique
» Installer plusieurs logiciels en une seule opération
» Chasse aux oeufs ( Place Longueuil ) au profit d'Opération Enfant Soleil
» Conversion fichier MVK

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum programmation :: Programmation :: Delphi & Pascal :: Pascal :: Cours-
Sauter vers: